nixos/modules/hardware/keychron/default.nix
Felix Buehler c48b59fe72
Some checks failed
/ Build Nix targets (push) Has been cancelled
hardware/keychron: use latest option
2025-05-06 00:12:01 +02:00

27 lines
396 B
Nix

{
config,
lib,
pkgs,
...
}:
let
cfg = config.my.hardware.keychron;
in
{
options.my.hardware.keychron = {
enable = lib.mkEnableOption "keychron configuration";
};
config = lib.mkIf cfg.enable {
hardware.keyboard.qmk.enable = true;
services.udev.packages = with pkgs; [
via
];
environment.systemPackages = with pkgs; [
qmk
via
];
};
}