mirror of
https://github.com/Stunkymonkey/nixos.git
synced 2025-05-24 01:44:40 +02:00
23 lines
330 B
Nix
23 lines
330 B
Nix
{
|
|
config,
|
|
lib,
|
|
pkgs,
|
|
...
|
|
}:
|
|
let
|
|
cfg = config.my.hardware.monitor;
|
|
in
|
|
{
|
|
options.my.hardware.monitor = {
|
|
enable = lib.mkEnableOption "monitor configuration";
|
|
};
|
|
|
|
config = lib.mkIf cfg.enable {
|
|
hardware.i2c.enable = true;
|
|
|
|
environment.systemPackages = with pkgs; [
|
|
ddcutil
|
|
ddcui
|
|
];
|
|
};
|
|
}
|