mirror of
https://github.com/Stunkymonkey/nixos.git
synced 2025-05-24 09:54:40 +02:00
17 lines
378 B
Nix
17 lines
378 B
Nix
{ config, lib, modulesPath, ... }:
|
|
{
|
|
imports = [ (modulesPath + "/profiles/qemu-guest.nix") ];
|
|
|
|
boot.initrd.availableKernelModules = [
|
|
"ata_piix"
|
|
"sd_mod"
|
|
"uhci_hcd"
|
|
"virtio_pci"
|
|
"virtio_scsi"
|
|
];
|
|
boot.initrd.kernelModules = [
|
|
"dm-snapshot"
|
|
];
|
|
|
|
hardware.cpu.amd.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
|
|
}
|